Scenario
Customer CPE is connecting to Access Point and NAT translation is done on the radio.

CPE is using PPPoE to login to base station.

Customer buy for example Firewall and he wants to have Public IP on the WAN port of his firewall.

Solution:

1. Setup Customer firewall to connect using PPPoE

2. Setup Customer CPE as wireless bridge (WDS)

Work flow

1.1. Login to firewall and setup it to connect with pppoe.

User: Company1

Password: Password1

2.1. Connect CPE to access point standard way and finish installation.

2.2. Backup Configuration on mikrotik

/system backup save name="backup before wds setup"

to restore backup

/system backup load name=”backup before wds setup”

2.3. Disable DHCP, NAT, Filter Rules, IP Address,

/ip firewall connection tracking set enabled=no
/ip firewall connection tracking set enabled=no
/ip dhcp-server set [find disabled=no] disabled=yes
/ip firewall nat set [find disabled=no] disabled=yes
/ip firewall filter set [find disabled=no] disabled=yes
/ip address set [find interface=ether1] disabled=yes

2.4. Setup Bridge

/interface bridge add

/interface bridge port add interface=ether1 bridge=bridge1

/interface bridge port add interface=wlan1 bridge=bridge1

2.5. Setup WDS on wlan1 interfase

/wnterface wireless set wlan1 mode=station-wds

2.6. Disable PPPoE

/interface pppoe-client set pppoe-out1 disabled=yes

Full Script

/ip firewall connection tracking set enabled=no
/ip dhcp-server set [find disabled=no] disabled=yes
/ip firewall nat set [find disabled=no] disabled=yes
/ip firewall filter set [find disabled=no] disabled=yes
/ip address set [find interface=ether1] disabled=yes
/interface bridge add
/interface bridge port add interface=ether1   bridge=bridge1
/interface bridge port add interface=wlan1   bridge=bridge1
/interface wireless set wlan1 mode=station-wds
/interface wireless set wlan1 wds-mode=dynamic wds-default-bridge=bridge1
/interface pppoe-client set pppoe-out1 disabled=yes

To check the settings login to the radio and paste:

/ip firewall connection tracking print
/ip dhcp-server print
/ip firewall nat print
/ip firewall filter print
/ip address print
/interface bridge print
/interface bridge port print
/interface wireless print
/interface pppoe-client print

To setup WDS on the transmiter

1. Add bridge1 OK

2. setup pppoe service on bridge1

3. setup wireless wlanx connection on wds tab wds dynamic interface bridge1.

/interface bridge add name=bridge1
/interface pppoe-server server add disabled=no interface=bridge1 service-name=service2 one-session-per-host=no
/interface wireless set wlan1 wds-mode=dynamic wds-default-bridge=bridge1 wds-ignore-ssid=no