1. Description

I am going to prepare Hotspot with fallowing futures.

  • User is able to signup on his first connection to the network over the wirelless.
  • User purchase monthly package with speed limit 1, 2, 3, Mbits using Paypal.
  • User able to login just after it with his username and password

2. Used equipment and preparation.

2.1. MikroTik RB 493AH lev.5 ROS 4.6 + User Manager 4.6 Test

2.2. links and downloads

2.2.1. ROS 4.6 download

2.2.2. User Manager Test 4.6 download

2.2.3. User Manager Test Forum link

3. Setup

3.1. Removing old config files and settings

3.1.1. In Winbox>Files remove all files

3.1.2. In New Terminal :

/tool user-manager database cleary/system reset-configurationy

3.2. Connect with winbox and setup internet connection.( In my case static Ip address on ether1 and local Ip on hotspot interface wlan1)

3.2.1. Universal Mikrotik settings
This include:

  •  Mikrotik User Password setup
  • IP services lock up to prevent box being hacked

CODE:

/user set admin password=mypassword
/ip service set ftp disabled=yes
/ip service set telnet disabled=yes
/ip service set ssh disabled=yes 
/ip service set www-ssl disabled=no
# Ip addresses for internet and hotspot interfacesip address add address=79.140.208.229/29 interface=ether1ip address add address=10.5.50.1/24 interface=wlan1# Route setupip route add gateway=79.140.208.225# DNS Setup
ip dns set servers=79.140.208.225,79.140.208.1

ip dns set servers=79.140.208.225,79.140.208.1

# Hotspot Setup
ip hotspot setup  #Select interface to run HotSpot on #hotspot interface: wlan1#Set HotSpot address for interface #local address of network: 10.5.50.1/24#masquerade network: yes#Set pool for HotSpot addresses #address pool of network: 10.5.50.2-10.5.50.254#Select hotspot SSL certificate #select certificate: none#Select SMTP server #ip address of smtp server: 79.140.208.140#Setup DNS configuration #dns servers: 79.140.208.225,79.140.208.1#DNS name of local hotspot server #dns name: hotspot.interpoint.ie#Create local hotspot user #name of local hotspot user: admin#password for the user: pass123
3.2.2. Wireless setup
/interface wireless set wlan1 ssid=PaypalHotspot band=2.4ghz-b/g mode=ap-bridge
3.2.3. User Manager setup
Check if your hotspot is working well with admin user created above.
remove admin user
/ip hotspot user print
# [[email protected]] > ip hotspot user print # Flags: X - disabled, D - dynamic # #   SERVER           NAME         ADDRESS         PROFILE         UPTIME      # 0                    admin                        default         2m41s
/ip hotspot user remove 0
/tool user-manager customer remove 0/tool user-manager customer add login=umadmin password=umpassword
/tool user-manager router add ip-address=127.0.0.1 shared-secret=123456 disabled=no name=hotspot customer=umadmin
/radius add service=hotspot address=127.0.0.1 secret=123456
/ip hotspot profile set 1 use-radius=yes